Ondersteuning oudere LTI-versies in Moodle

Learning Tools Interoperability

Met de internationale standaard Learning Tools Interoperability (LTI) kan je gemakkelijk leeractiviteiten uitwisselen tussen diverse leerplatformen. De standaard LTI is van het IMS Global Learning Consortium die ook andere standaarden beheert zoals SCORM en xAPI.

Met LTI kan je bijvoorbeeld een interactieve oefening of een complete cursus die gehost wordt ergens in de wereld tonen in je eigen leermanagementsysteem (LMS). Naast Single Sign On (SSO) worden ook alle leerresultaten (cijfers) gesynchroniseerd. Op deze manier koppel je op een eenvoudige manier externe leercontent in je eigen Moodle cursus.

Welke versie van LTI wordt geadviseerd?

Zoals bij elke IT-standaard maakt ook LTI een doorontwikkeling door. De meeste organisaties die hun leercontent aanbieden hebben versie 1.1 en 1.2 geïmplementeerd. Ook de meeste LMS-en gebruiken diezelfde versies. De meeste recente versies zijn LTI 1.3 en LTI Advantage. De ondersteuning van alle oudere versies stopt na 30 juni 2022. Eén van de belangrijkste redenen is dat oudere versies nog OAuth 1.0a gebruiken en die wordt ook niet meer ondersteund. LTI 1.3 en LTI Advantage maken gebruiken van OAuth 2. Dus ook vanuit het oogpunt van informatiebeveiliging en privacy moet elk LMS en elke aanbieder van leercontent naar de nieuwste LTI versie upgraden. Lees meer op de site van IMS Global hierover.

LTI 1.3 en Moodle?

Hoe gaat Moodle om met het implementeren van LTI 1.3? In mei 2019 kwam Moodle 3.7 uit en daarin was al ondersteuning opgenomen voor LTI 1.3 en LTI Advantage. In hetzelfde voorjaar werd Moodle gecertificeerd door IMS Global en dat betekent dat de ontwikkelaars van Moodle de LTI-standaard op de juiste manier hebben geïmplementeerd in de software. Ook leuk om te melden is dat Moodle het eerste LMS ter wereld was die deze certificering ontving. Moodle blijft een LMS dat voorop blijft lopen qua ontwikkelingen.

Goed dat Moodle de nieuwe LTI-standaarden ondersteund, maar wat betekent dit voor mijn bestaande LTI-koppelingen met versie 1.1 en 1.2? Blijven die nog werken in nieuwe Moodle versies? Uit deze forumdiscussie blijkt dat oudere LTI-versies voorlopig nog intact blijven. Wel zal er een waarschuwing getoond worden bij het beheer van de LTI-koppeling dat er verouderde versies gebruikt worden. Er zijn op dit moment nog geen plannen om de code van de verouderde LTI-versies uit Moodle te halen. Maar hoelang Moodle dit kan blijven volhouden is onbekend.

Wil je testen of een LTI-koppeling met versie 1.3 werkt, gebruik dan een (recente) Moodle site of deze LTI Tool Emulator.

Ons advies: als je een verouderde LTI-koppeling tegenkomt, meldt dit dan bij de aanbieder van de leercontent of bij de LMS-leverancier. Wijs hen op de veiligheidsrisico’s die er zijn met de oudere versies.

Ben je op zoek naar een goede LTI-provider en wil je makkelijk en snel je leercontent delen via LTI? Kijk dan eens naar LTIprovider.net.

Blijf op de hoogte

Vul je e-mailadres in en lees als eerste onze blogs over Moodle.

Voeg je bij 459 andere abonnees
Hand click
Nieuws en tips over Moodle

Ontvang van elke blog die wij schrijven een notificatie op je e-mailadres, zodat je goed op de hoogte blijft over Moodle.
Afmelden is altijd mogelijk.

Voeg je bij 459 andere abonnees